**User Guide for Bridge Rail Expert System (BREXS)**

This guide is intended to serve highway engineers as an introduction to the usage of BREXS, a knowledge-based expert system for bridge rail selection. Both new construction and retrofit cases of rail selection and installation are treated. Following instructions for installation of the software and required microcomputer hardware, the user is instructed in use of the software under the Microsoft Windows environment. Each menu in the system is described in detail. Graphical images from the computer monitor illustrate entry to data and dialog boxes as well as drawings of bridge rails that can be moved horizontally with the keyboard or pointing device to desired or optimal locations on the existing bridge slab. The final chapter provides the user with a sample session that uses the program to aid in bridge rail selection. Rails are recommended for a given site from a list of standard types approved by the Texas Department of Transportation.

**Key Words**
Bridge Rail, Expert System, Fuzzy Logic, Heuristic, Highway, Knowledge Base, Retrofit, Transportation

**Distribution Statement**
No restrictions. This document is available to the public through the National Technical Information Service 5285 Port Royal Road Springfield, Virginia 22161

Form DOT F 1700.7 (8-69)
User Guide for Bridge Rail EXpert System (BREXS)

by

Paul N. Roschke
Assistant Research Engineer

and

Prakit Premthamkorn
Wajeeh A. Mitri
Graduate Research Assistants

Research Report 1240-1

on

Expert System for Bridge Rail Design

Research Study No. 2-5-90-1240

Sponsored by

Texas Department of Transportation

in cooperation with

The United States Department of Transportation

Federal Highway Administration

September, 1991

Texas Transportation Institute
The Texas A&M University System
College Station, Texas 77843-3135
# METRIC (SI*) CONVERSION FACTORS

## APPROXIMATE CONVERSIONS TO SI UNITS

<table>
<thead>
<tr>
<th>Symbol</th>
<th>When You Know</th>
<th>Multiply By</th>
<th>To Find</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>in</td>
<td>inches</td>
<td>2.54</td>
<td>cm</td>
<td>cm</td>
</tr>
<tr>
<td>ft</td>
<td>feet</td>
<td>0.3048</td>
<td>m</td>
<td>m</td>
</tr>
<tr>
<td>yd</td>
<td>yards</td>
<td>0.914</td>
<td>m</td>
<td>m</td>
</tr>
<tr>
<td>mi</td>
<td>miles</td>
<td>1.61</td>
<td>km</td>
<td>km</td>
</tr>
</tbody>
</table>

### LENGTH

<table>
<thead>
<tr>
<th>Symbol</th>
<th>When You Know</th>
<th>Multiply By</th>
<th>To Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>mm</td>
<td>millimetres</td>
<td>0.039</td>
<td>inches</td>
</tr>
<tr>
<td>m</td>
<td>metres</td>
<td>3.28</td>
<td>feet</td>
</tr>
<tr>
<td>m</td>
<td>metres</td>
<td>1.09</td>
<td>yards</td>
</tr>
<tr>
<td>km</td>
<td>kilometres</td>
<td>0.621</td>
<td>miles</td>
</tr>
</tbody>
</table>

### AREA

<table>
<thead>
<tr>
<th>Symbol</th>
<th>When You Know</th>
<th>Multiply By</th>
<th>To Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>in²</td>
<td>square inches</td>
<td>645.2</td>
<td>cm²</td>
</tr>
<tr>
<td>ft²</td>
<td>square feet</td>
<td>0.0929</td>
<td>m²</td>
</tr>
<tr>
<td>yd²</td>
<td>square yards</td>
<td>0.836</td>
<td>m²</td>
</tr>
<tr>
<td>mi²</td>
<td>square miles</td>
<td>2.59</td>
<td>km²</td>
</tr>
<tr>
<td>ac</td>
<td>acres</td>
<td>0.395</td>
<td>ha</td>
</tr>
</tbody>
</table>

### MASS (weight)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>When You Know</th>
<th>Multiply By</th>
<th>To Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>oz</td>
<td>ounces</td>
<td>28.35</td>
<td>g</td>
</tr>
<tr>
<td>lb</td>
<td>pounds</td>
<td>0.454</td>
<td>kg</td>
</tr>
<tr>
<td>T</td>
<td>short tons</td>
<td>0.907</td>
<td>Mg</td>
</tr>
</tbody>
</table>

### VOLUME

<table>
<thead>
<tr>
<th>Symbol</th>
<th>When You Know</th>
<th>Multiply By</th>
<th>To Find</th>
</tr>
</thead>
<tbody>
<tr>
<td>fl oz</td>
<td>fluid ounces</td>
<td>29.57</td>
<td>mL</td>
</tr>
<tr>
<td>gal</td>
<td>gallons</td>
<td>3.785</td>
<td>L</td>
</tr>
<tr>
<td>ft³</td>
<td>cubic feet</td>
<td>0.0328</td>
<td>m³</td>
</tr>
<tr>
<td>yd³</td>
<td>cubic yards</td>
<td>0.0765</td>
<td>m³</td>
</tr>
</tbody>
</table>

### TEMPERATURE (exact)

<table>
<thead>
<tr>
<th>°F Fahrenheit</th>
<th>°C Celsius</th>
<th>°F Fahrenheit</th>
<th>°C Celsius</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/9 (after subtracting 32)</td>
<td>9/5 (then add 32)</td>
<td>-40</td>
<td>40</td>
</tr>
<tr>
<td>0</td>
<td>32</td>
<td>80</td>
<td>120</td>
</tr>
</tbody>
</table>

These factors conform to the requirement of FHWA Order 5190.1A.

* SI is the symbol for the International System of Measurements.
ABSTRACT

This guide is intended to serve highway engineers as an introduction to the usage of BREXS, a knowledge-based expert system for bridge rail selection. Both new construction and retrofit cases of rail selection and installation are treated. Following instructions for installation of the software and required microcomputer hardware, the user is instructed in use of the software under the Microsoft Windows environment. Each menu in the system is described in detail. Graphical images from the computer monitor illustrate entry to data and dialog boxes as well as drawings of bridge rails that can be moved horizontally with the keyboard or pointing device to desired or optimal locations on the existing bridge slab. The final chapter provides the user with a sample session that uses the program to aid in bridge rail selection. Rails are recommended for a given site from a list of standard types approved by the Texas Department of Transportation.
DISCLAIMER

The contents of this report reflect the views of the authors who are responsible for the opinions, findings, and conclusions presented herein. The contents do not necessarily reflect the official views or policies of the Texas Department of Transportation. This report does not constitute a standard, specification, or regulation. This report is not intended for construction, bidding, or permit purposes.

KEY WORDS


ACKNOWLEDGEMENTS

This study was conducted under a cooperative program between the Texas Transportation Institute, the Texas Department of Transportation, and the Federal Highway Administration. John Panak and Mark Bloschock of TxDOT worked closely with the researchers, and their comments and suggestions are appreciated.
IMPLEMENTATION STATEMENT

The main objective of this research study was to develop an expert system which would help in selecting and designing bridge rails. This system, called Bridge Rail EXpert System, or BREXS, is designed for use by both experienced and inexperienced design engineers at the district level throughout Texas. In addition, its graphical, user-oriented interface facilitates its use by engineers with little or no computer experience. BREXS can be used mainly for the following purposes:

1. Aid inexperienced engineers to gain some insight as to how and why rail types are selected or designed.
2. Encourage more uniformity in the design or selection process at all district offices of Texas Department of Transportation.
3. Optimize the selection process according to five factors: cost, maintenance, safety, aesthetics, and personal preference.
4. Expedite the design process of retrofitting since the design review can be reduced and made less time consuming.

To obtain these benefits, it is suggested that a copy of BREXS be installed on a microcomputer in each of the TxDOT district offices. Moreover, the use of BREXS by design engineers and reviewers should be encouraged or even required. Further research is needed to investigate the best approach for making use of BREXS or other expert systems in the same field.

Results of this study are available for immediate implementation by the Texas Department of Transportation.

COPYRIGHT (c) 1991, Texas Transportation Institute, All Rights Reserved.

Use of the software, or documentation in whole or part within the body of another work, except for brief citations, is prohibited. Selling or redistributing the software, or documentation by any person or agency other than TTI and their authorized agents is prohibited.
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abstract</td>
<td>iv</td>
</tr>
<tr>
<td>Disclaimer</td>
<td>v</td>
</tr>
<tr>
<td>Implementation Statement</td>
<td>vi</td>
</tr>
<tr>
<td>List of Figures</td>
<td>ix</td>
</tr>
<tr>
<td>I. Installation and Use of BREXS</td>
<td>1</td>
</tr>
<tr>
<td>1.1 Introduction</td>
<td>1</td>
</tr>
<tr>
<td>1.2 Setting Up BREXS</td>
<td>2</td>
</tr>
<tr>
<td>1.3 Using the Advisory Program</td>
<td>7</td>
</tr>
<tr>
<td>II. Detailed Description of Menus</td>
<td>10</td>
</tr>
<tr>
<td>2.1 File Menu</td>
<td>10</td>
</tr>
<tr>
<td>2.1.1 Creating a New Data File</td>
<td>10</td>
</tr>
<tr>
<td>2.1.2 Reading a Data File</td>
<td>11</td>
</tr>
<tr>
<td>2.1.3 Saving Case Data to a File</td>
<td>11</td>
</tr>
<tr>
<td>2.1.4 Printing Case Data</td>
<td>12</td>
</tr>
<tr>
<td>2.1.5 Exiting BREXS</td>
<td>12</td>
</tr>
<tr>
<td>2.2 Edit Menu</td>
<td>14</td>
</tr>
<tr>
<td>2.2.1 Editing Roadway Data</td>
<td>14</td>
</tr>
<tr>
<td>2.2.2 Editing Bridge Data</td>
<td>15</td>
</tr>
<tr>
<td>2.2.3 Editing Environment Data</td>
<td>17</td>
</tr>
<tr>
<td>2.2.4 Editing Construction Data</td>
<td>18</td>
</tr>
<tr>
<td>2.2.5 Editing Weights of Importance</td>
<td>19</td>
</tr>
<tr>
<td>2.2.6 Editing Existing Bridge Data</td>
<td>21</td>
</tr>
<tr>
<td>2.3 Execute Menu</td>
<td>24</td>
</tr>
<tr>
<td>2.3.1 Running the Advisory Program</td>
<td>24</td>
</tr>
<tr>
<td>2.3.2 Draw</td>
<td>25</td>
</tr>
<tr>
<td>2.4 Results Menu</td>
<td>27</td>
</tr>
<tr>
<td>2.4.1 How to View Recent Results</td>
<td>27</td>
</tr>
<tr>
<td>2.4.2 Closing the Results Window</td>
<td>28</td>
</tr>
<tr>
<td>2.4.3 Saving Results to a File</td>
<td>28</td>
</tr>
<tr>
<td>2.4.4 Printing Results</td>
<td>28</td>
</tr>
<tr>
<td>2.4.5 How to View Old Results</td>
<td>28</td>
</tr>
<tr>
<td>2.5 Rail Types Menu</td>
<td>29</td>
</tr>
<tr>
<td>2.5.1 Rail Types Database Record Structure</td>
<td>29</td>
</tr>
<tr>
<td>2.5.2 Accessing the Rail Types Database</td>
<td>30</td>
</tr>
<tr>
<td>2.5.3 Browsing the Rail Types Database</td>
<td>30</td>
</tr>
<tr>
<td>2.5.4 Adding a New Record to the Rail Database</td>
<td>30</td>
</tr>
<tr>
<td>2.5.6 Editing Records in the Rail Types Database</td>
<td>31</td>
</tr>
<tr>
<td>2.5.7 Deleting Records from the Rail Database</td>
<td>31</td>
</tr>
</tbody>
</table>
### LIST OF FIGURES

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>New Program Object Dialog Box</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>Program Group Properties Dialog Box</td>
<td>4</td>
</tr>
<tr>
<td>3</td>
<td>Program Item Properties Dialog Box</td>
<td>4</td>
</tr>
<tr>
<td>4</td>
<td>Program Item Properties Dialog Box</td>
<td>5</td>
</tr>
<tr>
<td>5</td>
<td>PIF Edition for BCAP1.EXE File</td>
<td>5</td>
</tr>
<tr>
<td>6</td>
<td>PIF Edition for BCAP2.EXE File</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>BREXS Program Group Window</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>BREXS Main Window</td>
<td>8</td>
</tr>
<tr>
<td>9</td>
<td>Warning Message Box</td>
<td>10</td>
</tr>
<tr>
<td>10</td>
<td>Dialog Box for File Open</td>
<td>11</td>
</tr>
<tr>
<td>11</td>
<td>Dialog Box for Saving a File</td>
<td>12</td>
</tr>
<tr>
<td>12</td>
<td>EXIT Warning Message Box</td>
<td>13</td>
</tr>
<tr>
<td>13</td>
<td>Dialog Box for Project ID Information</td>
<td>13</td>
</tr>
<tr>
<td>14</td>
<td>Dialog Box for Bridge Data</td>
<td>17</td>
</tr>
<tr>
<td>15</td>
<td>Dialog Box for Environment Data</td>
<td>18</td>
</tr>
<tr>
<td>16</td>
<td>Dialog Box for Construction Data</td>
<td>19</td>
</tr>
<tr>
<td>17</td>
<td>Dialog Box for Weights of Importance</td>
<td>20</td>
</tr>
<tr>
<td>18</td>
<td>Dialog Box for Edit Existing Bridge Data</td>
<td>21</td>
</tr>
<tr>
<td>19</td>
<td>Slab Drawing Window and Slab Dimensions Input Dialog Box</td>
<td>22</td>
</tr>
<tr>
<td>20</td>
<td>Types of Bridge Deck Available in BREXS Database</td>
<td>23</td>
</tr>
<tr>
<td>21</td>
<td>Message to User During Execution</td>
<td>24</td>
</tr>
<tr>
<td>22</td>
<td>Draw Window</td>
<td>25</td>
</tr>
<tr>
<td>23</td>
<td>T4 Rail Placed at the Optimal Position</td>
<td>26</td>
</tr>
<tr>
<td>24</td>
<td>Results Window</td>
<td>27</td>
</tr>
<tr>
<td>25</td>
<td>Dialog Box for Rail Types Database</td>
<td>30</td>
</tr>
<tr>
<td>26</td>
<td>Show Rail Window</td>
<td>32</td>
</tr>
<tr>
<td>27</td>
<td>Help Menu with BREXS Information</td>
<td>33</td>
</tr>
<tr>
<td>28</td>
<td>Existing Bridge Structure Data Input Screen</td>
<td>35</td>
</tr>
<tr>
<td>29</td>
<td>Slab Type and Dimension Input Windows</td>
<td>35</td>
</tr>
<tr>
<td>30</td>
<td>Highway Information Screen</td>
<td>37</td>
</tr>
<tr>
<td>31</td>
<td>Bridge Data Screen</td>
<td>37</td>
</tr>
<tr>
<td>32</td>
<td>Environment Information Screen</td>
<td>38</td>
</tr>
<tr>
<td>33</td>
<td>Parameter Weighting Data Screen</td>
<td>38</td>
</tr>
<tr>
<td>34</td>
<td>List of Selected Rails</td>
<td>39</td>
</tr>
<tr>
<td>35</td>
<td>Recommended Placement Position on the Slab (T4)</td>
<td>40</td>
</tr>
<tr>
<td>36</td>
<td>Recommended Placement Position on the Slab (T501)</td>
<td>40</td>
</tr>
</tbody>
</table>
I. INSTALLATION AND USE OF BREXS

1.1 Introduction

*BREXS* is an advisory system for selection of bridge rails. Rails are recommended for a given site from a list of standard rail types approved by the Texas Department of Transportation (TxDOT). Input to the advisory program is information relating to the bridge in question, the roadway, and the surrounding environment. Output from the program is a list of recommended rail types in a ranked order of preference. Users also have the ability to control the selection criteria. With *BREXS*, data for a specific case can be entered, edited, saved in a data file for later reference and, at a later date, read from a data file. Results can also be saved in a file along with the case data. A facility to print either the case data or the results is also included.

*BREXS* also has the ability to access a bridge rail database, in which information specific to each approved rail is stored. Addition and deletion of rail types to and from the database can also be performed.

This guide for users of *BREXS* is divided into three main sections. In the first section (Chapter 1) a brief installation procedure and general operation conventions are described. Chapter 2 gives narrative information and engineering details about each item in the menus that the user has control over. This chapter is divided into subsections that correspond to entries in the main menu of *BREXS*. The primary entries are as follows:

* **File:** Commands for handling data files.

* **Edit:** Commands for editing case data.

* **Execute:** Command to execute the advisory program.

* **Results:** Commands to show, print, and save results.

* **Rail Types:** Commands to show rail cross sections and access the database of rail types.

* **Help:** Commands to help the user when running *BREXS*. 
In the final section (Chapter 3) a sample session involving a typical bridge rail design is given by means of narrative and images of the computer screen. A companion report (Roschke 1991) that describes the knowledge acquisition and technical details of BREXS is listed in the Appendix.

There are two versions of BREXS, both of which are documented in this report. One gives advice for installation of railings on new bridges that are being designed, while the other deals with retrofit railing problems. The new construction version of BREXS selects bridge rails for newly constructed bridges. The retrofit version selects bridge rails to replace old and substandard rail on existing bridges. Both versions employ a similar user interface but each has a unique and separate knowledge base. A user chooses the version that corresponds to the type of problem to be solved.

As mentioned earlier, both versions of BREXS have a similar user interface. The main windows and primary menus are identical. However, the retrofit version requires input of existing bridge geometry information. It also features graphics capable of showing the optimal position of each candidate rail on the given bridge structure. These two functions are accomplished by use of the Existing Bridge Data and Draw submenus under Edit and Execute, respectively.

The explanation in this user's guide is applicable to both versions of BREXS. Specific features that differ are specified.

1.2 Setting Up BREXS

BREXS runs only under Microsoft Windows. Before installing BREXS make sure that version 3.0 or later of Microsoft Windows executes correctly on the microcomputer. BREXS and its related files are contained on two diskettes labeled as follows: BREXS-New Construction and BREXS-Retrofit. A mouse pointing device and a hard disk are assumed to be available. It is recommended that BREXS be run from the hard disk. The following steps outline the installation procedure.

1. Make a directory called BREXS on the hard disk. Then, create subdirectories NEWCON and RETROFIT under this directory. Assuming BREXS is to be installed on drive C, the DOS commands to carry out these step are as follows:
2. Copy all files from the diskette labeled BREXS-New Construction to the subdirectory NEWCON that is under directory BREXS on the hard disk. This can be done by the following DOS command, assuming that A is the diskette drive and C is the hard disk drive:

C: \> COPY A:*.* C:\BREXS\NEWCON

3. Copy all files from the diskette labeled BREXS-Retrofit to the subdirectory RETROFIT under directory BREXS on the hard disk. This can be done by the following DOS command, assuming that A is the floppy disk drive and C is the hard disk drive:

C: \> COPY A:*.* C:\BREXS\RETROFIT


5. Create a new program group for BREXS. This can be done by clicking New under File menu within the Program Manager window. Choose Program Group in the New Program Object dialog box as shown in Fig. 1. Click on the OK button. The Program Group Properties dialog box appears on the screen (Fig. 2). Type BREXS in the Description box. Leave the Group File box blank. Then click the OK button. The BREXS program group window appears on the screen.

6. Create new program items for the BREXS program group. This can be done by selecting New under the File menu. The New Program Object dialog box, similar to step 5 above, appears on the screen. Choose Program Item. After clicking on the OK button, the Program Item Properties dialog box appears on the screen. Type in the boxes as shown in Fig. 3. Click on the OK button. The icon for New Construction appears in the BREXS program group.
7. To define the startup icon for the retrofit program repeat step 6 but fill in the boxes as shown in Fig. 4.

---

**FIG. 1.** New Program Object Dialog Box

---

**FIG. 2.** Program Group Properties Dialog Box

---

**FIG. 3.** Program Item Properties Dialog Box
8. Open the PIF Editor program that is located in the Accessories group. Choose **Open** from the **File** menu and open the file "BCAP1.PIF" from the new directory that was created in step 1. Move the mouse to the box next to **Program Filename** and click once with the left mouse button. Enter the complete path of the directory that was created in step 1 and the file name BCAP1.EXE. For example, type the following:

C:\BREXS\NEWCON\BCAP1.EXE

Move the mouse to the box next to **Start-up Directory** and click once with the left mouse button. Enter the complete path of the directory that was created in step 1. For example:

C:\BREXS\NEWCON

The PIF Editor dialog box should now appear as shown in Fig 5. Choose **Save** from the **File** menu and then **Exit**.

**FIG. 5. PIF Edition for BCAP1.EXE File**
9. Repeat step 8 but this time open the file "BCAP2.PIF" from the directory \BREXS\RETROFIT. Specify the Program Filename as:

   C:\BREXS\RETROFIT\BCAP2.EXE

Enter the Start-up Directory as:

   C:\BREXS\RETROFIT

The PIF Editor dialog should now appear as shown in Fig. 6. Choose Save from the File menu and then select Exit.

![PIF Editor dialog](image)

**FIG. 6. PIF Edition for BCAP2.EXE File**

10. To make sure that the operation was successful, open the BREXS program group and verify that two icons with the name of New Construction and Retrofit appear in that window (see Fig. 7). If this icon is not visible, repeat steps 6 and 7 or refer to "Adding Existing Applications" in Appendix A of the Microsoft Windows User's Guide (Microsoft 1990).

11. Add the directory in which BREXS is installed to the PATH variable in the AUTOEXEC.BAT file. This environment variable should be similar to the following command:

   SET PATH = C:\BREXS\NEWCON; C:\BREXS\RETROFIT

12. Reboot the computer in order to activate the changes made to the AUTOEXEC.BAT file.
13. **BREXS** requires NEXPERT *OBJECT* runtime or development version for execution of the inference engine. Install NEXPERT *OBJECT* according to its installation guide. Make sure that the environmental path variable contains a reference to the directory where the NEXPERT *OBJECT* files are contained. In addition, a hardware protection key must be attached to the parallel port of the microcomputer to start the advisory program **BREXS**.

![BREXS Program Group Window](image)

**FIG. 7. BREXS Program Group Window**

### 1.3 Using the Advisory Program

The **BREXS** advisory system is intended for use as a consultant for selecting a rail type for a specific bridge site. This section provides an overview of control and execution of the New Construction and Retrofit programs. Sections that follow give more detailed information for each menu and option that is available.

Before starting the advisory program, relevant data about bridge, roadway, construction technique, and environment need to be known or estimated. Existing bridge geometry is also required. A determination needs to be made regarding numerical values for weights of importance for the following five categories that affect rail selection: cost, maintenance, strength, aesthetics, and personal preference. After running the advisory program results can be displayed on the screen, saved to a file, or printed. Data for a given case can also be saved for later retrieval. The following steps outline the procedure to obtain expert advice from the system:
1. If BREXS is correctly installed, it can be run under Microsoft Windows. First open the Windows Application group. Then, click twice on the New Construction icon (or Retrofit icon) in the BREXS program group window. Alternatively, BREXS can be invoked by selecting the appropriate icon and choosing Open from the File menu of the Program Manager window. The main window for BREXS appears on the screen (Fig. 8).

![Fig. 8. BREXS’ Main Window](image)

2. Select New from the File menu of BREXS.

3. Use the Edit menu to input the data under the following selections: Existing Bridge Data (for retrofit only), Roadway Data, Bridge Data, Environmental Data, Construction Data (for new construction only), and Weight of Importance. Note that when any of the dialog boxes are open, all other BREXS functions are disabled. Hence, only one dialog box can be open at a time. When all questions have been answered, the dialog box is closed by moving the mouse to the OK button and clicking once with the left mouse button. This saves the data entered into memory. The Cancel button can also be used to close a dialog box, but it results in losing any changes made to the data. Answer questions in the form by
selecting and entering the relevant data for the bridge site. When these
selections are complete choose OK to save the data or Cancel to abort the input
process. Notice that when an option from the Edit menu has been chosen and
data has been entered successfully, a check mark is placed by the side of that
option. Refer to the corresponding section in this manual for further
explanation of each question in the form.

4. When finished entering or editing the case data select Run Advisory Program
from the Execute menu.

5. After execution, results can be viewed by choosing Show Results from the
Results menu.

6. For the retrofit version, select Draw under Execute to invoke the draw
program. Draw shows graphical images of rails on the existing bridge at the
recommended optimal position.

7. To save the case data and results, choose Save Results from the Results menu.

8. To print the results, choose Print Results from the Results menu.

9. The Rail Types menu provides access to the bridge rail database and
drawings.

10. Help provides on-line documentation of the system.
II. **Detailed Description of Menus**

2.1 **File Menu**

This menu offers selections that manipulate data and data files. In addition, it includes commands to terminate operation of BREXS or to print the data. Each option is described in the following sections.

2.1.1 **Creating a New Data File**

To create a new data file select the option `New`. This sets the input data variables for an advisory session to their default values. If data have already been edited, or if a data file has been previously set, a message box appears to warn the user of the possibility of losing the old data (see Fig. 9). The user has a choice of canceling the operation or replacing the old data with the new default values.

When a new file is created a dialog box appears (Fig. 13). Enter the project information requested in the dialog box. To do this, move the mouse cursor inside the box in which you want to enter the information, click once on the left-hand button, then use the keyboard to enter the information. The same effect can be obtained without the mouse by using the tab key on the keyboard. When the information has been entered, click on the **OK** button in the dialog box.

![FIG. 9. Warning Message Box](image)
2.1.2 Reading a Data File

To open an existing file which contains data from a previously entered case, choose Open from the File menu. A dialog box appears (Fig. 10). Either enter the filename along with its complete path or select the path and the required file from the list of files shown in the dialog box. It is recommended that file names for new construction and retrofit bridges end with .BRX and .RET, respectively, as the extension.

![Dialog Box for File Open](image)

**FIG. 10. Dialog Box for File Open**

2.1.3 Saving Case Data to a File

To save data for a specific case in a file, choose Save from the File menu. If a file has not been saved before, a dialog box appears (Fig. 11). Enter the name of the file in the space provided. Select OK to continue or Cancel to abort. The default extension .BRX is optional but recommended. If the file has been previously saved, no dialog box appears and the old file is replaced.

The Save As option in the File menu performs the same operation as Save except for two aspects. First, each time Save As is chosen, the project information
dialog box appears (Fig. 13). A user can edit the information in the box if required. Second, the user is prompted for a file name each time Save As is chosen.

2.1.4 Printing Case Data

To print data displayed on the screen choose Print Data from the File menu. This results in the case-specific data being printed in the same format as shown in the main window of BREXS.

2.1.5 Exiting BREXS

To terminate operation of BREXS, choose Exit BREXS from the File menu. If data have been edited and the file has not been saved since the last change, a message box (Fig. 12) is displayed to give the user a choice of either terminating the program without saving the changed data, or canceling the Exit operation.

FIG. 11. Dialog Box for Saving a File
Highway = Ualn Lane
Percent Trucks = 10 Percent
Average Daily Traffic = 8,000 vpd
Rail Offset is 3 to 7 ft. from edge of Travelway to Face of Rail
Type of Understructure = Low Occupancy Land
Grade = 0.0 Percent
Curvature = 0.0 Degrees
Curvature Length = 0
Bridge Length = 100.0
Bridge Width = 40.0'
Deck Thickness = 10.0
Maximum Approach Length =
Bridge Deck Height =
Bridge Location = urban
Temporary Rails Are To
Weight of Importance for Maintenance is 10 out of 10
Weight of Importance for Strength is 9 out of 10
Weight of Importance for Aesthetics is 2 out of 10
Weight of Importance for Personal Preference is 5 out of 10

FIG. 12. EXIT Warning Message Box

FIG. 13. Dialog Box for Project ID Information
2.2 Edit Menu

This menu supplies the user with functions that allow data to be modified before the advisory program is executed. Data are divided into five sets. Four of these sets (roadway, bridge, construction, and environment) deal with information about a specific case. The fifth set, weight of importance, controls the criteria by which rail types are recommended. After data has been edited in a given set, a check mark appears next to the name of that set in the Edit menu.

Submenus Roadway Data, Bridge Data, Environmental Data, and Weight Of Importance are used in both the new construction and the retrofit version of BREXS. However, Construction Data and Existing Bridge Data submenus are specific to the new construction and retrofit programs, respectively.

2.2.1 Editing Roadway Data

Roadway data are edited by selecting Roadway Data from the Edit menu. A dialog box appears. To edit roadway data answer the following questions and perform the described actions:

- Design Speed: What is the design speed of the roadway?
  Choose the design speed from the given list by moving the mouse to the circle next to the desired number and then clicking once on the left mouse button.

- Percent Trucks: From a total of all vehicles that use the road what is the percentage of heavy trucks?
  Choose a number from the given list that is closest to this percentage by moving the mouse to the circle next to the desired number and clicking once on the left mouse button.

- Type of Roadway: What is the type of the roadway?
  Choose the type of roadway from the given list by moving the mouse to the circle next to the desired type and clicking once on the left mouse button.

- Average Daily Traffic: What is the Average Daily Traffic (ADT) on the roadway?
  Move the mouse to the rectangle next to the words "Average Daily Traffic" and click once with the left mouse button. Use the keyboard to enter the average number of vehicles that use the roadway in one day, in thousands of vehicles. For example, if the ADT is 2550, then enter 2.55 in the box.

- Potential Turning Movements?: Are there any side roads that feed traffic into the roadway such that turning movements are expected?
Move the mouse to the square next to this question and click with the left mouse button if the answer to this question is "yes." If the answer to the question is "no," there is no need to perform this operation.

- **Record of Multiple Impacts?**: Is there a record of multiple impacts associated with this roadway? Move the mouse to the square next to this question and click with the left mouse button if the answer to the question is "yes." If the answer to the question is "no," there is no need to perform this operation.

- **Visibility for Safety Required?**: Is visibility through or above the rail required for safety reasons? Move the mouse to the square next to this question and click with the left mouse button if the answer to this question is "yes." If the answer is "no," there is no need to perform this operation.

### 2.2.2 Editing Bridge Data

Data related to the bridge itself is input or changed by selecting **Bridge Data** from the **Edit** menu. A dialog box appears (Fig. 14). To edit this data answer the following questions and perform the described actions:

- **Bridge Rail Offset**: What is the distance between the edge of the roadway and the face of the rail?
  Choose the closest offset from the given list by moving the mouse to the circle next to the desired range. Click once with the left mouse button to make the selection.

- **Type of Understructure**: What is underneath the bridge?
  Choose one of the answers given in the list by moving the mouse to the circle next to the desired answer and then clicking once with the left mouse button. If the answer is "Highway," enter the ADT in the box next to this answer in the same way that the ADT is entered in the **Roadway Data** dialog box.

- **Grade in Traffic Direction**: What is the percent grade of the roadway in the direction of the traffic flow?
  Move the mouse to the rectangle next to the words "Grade in Traffic Direction" and click once with the left mouse button. Use the keyboard to enter the percent grade. For example, for a roadway with a 5% grade enter 5.0.

- **Degree of Curvature in Traffic Direction**: What is the curvature of the roadway measured in degrees in the direction of the traffic flow?
  Move the mouse to the rectangle next to the words "Degree of Curvature in Traffic Direction" and click once with the left mouse button.
button. Use the keyboard to enter the curvature of the roadway in degrees. For example, for a curvature of 15 degrees enter 15.0.

- **Curvature Length**: What is the length of the curvature in the roadway, if any? 
  Move the mouse to the rectangle next to the words "Curvature Length" and click once with the left mouse button. Use the keyboard to enter the length of the curvature in the roadway, measured in feet. If the roadway has no curvature, enter 0.0.

- **Length of Bridge**: What is the length of the bridge measured in feet? 
  Move the mouse to the rectangle next to the words "Length of Bridge" and click once with the left mouse button. Use the keyboard to enter the length of the bridge measured in feet.

- **Clear Roadway Width**: What is the clear width of the roadway, measured in feet? 
  Move the mouse to the rectangle next to the words "Width of Bridge" and click once with the left mouse button. Use the keyboard to enter the width of the bridge in units of feet measured from the nominal face of the rail.

- **Thickness of Slab**: What is the thickness of the bridge slab? 
  Move the mouse to the rectangle next to the words "Thickness of Slab" and click once with the left mouse button. Use the keyboard to enter the thickness of the deck slab measured in inches.

- **Maximum Approach Length**: What is the maximum approach distance that can be used? 
  Move the mouse to the rectangle next to the words "Maximum Approach Length" and click once with the left mouse button. Use the keyboard to enter the maximum distance measured in feet that can be used for the approach section of the rail.

- **Height Above Understructure**: How high is the bridge above what is being traversed? 
  Move the mouse to the rectangle next to the words "Height Above Understructure" and click once with the left mouse button. Use the keyboard to enter the distance from the bridge deck to the understructure measured in feet.

- **Bridge Has Sidewalk?**: Does the bridge have a sidewalk? 
  Move the mouse to the square next to this question and click with the left mouse button if the answer is "yes." If the answer is "no" there is no need to perform an operation.

- **Bridge Length Culvert?**: Is the railing to be placed on a bridge length culvert? 
  Move the mouse to the square next to this question and click with the left mouse button if the answer is "yes." If the answer is "no" there is no need to perform an operation.
2.2.3 Editing Environment Data

Data for the bridge environment is edited by selecting Environment Data from the Edit menu. A dialog box appears (Fig. 15). To edit environmental data answer the following questions and perform the described actions:

- **Bridge location:** In which area is the bridge located?
  Choose the area in which the bridge is located from the given list by moving the mouse to the circle next to the desired choice and then clicking once with the left mouse button.

- **Deicing salt used?:** Is deicing salt used regularly on the bridge?
  Move the mouse to the square next to that question and click on the left mouse button if the answer is "yes." If the answer to the question is "no" there is no need to perform an operation.

- **High velocity hydraulics required?:** Does the bridge require high velocity hydraulics because of the high possibility of flooding?
  Move the mouse to the square next to this question and click on the left mouse button if the answer is "yes." If the answer is "no" there is no need to perform an operation.
2.2.4 Editing Construction Data

This submenu is specific to the new construction version of BREXS only. Data related to construction is edited by selecting Construction Data from the Edit menu. A dialog box appears (Fig. 16). To edit the construction data answer the following questions and perform the described actions:

- **Construction phasing?** Is construction of this bridge to be executed in phases? Move the mouse to the square next to this question and click with the left mouse button if the answer is "yes." If the answer is "no" there is no need to perform an operation.

- **Temporary rails used?** Are temporary rails to be used during construction? Move the mouse to the square next to this question and click with the left mouse button if the answer is "yes." If the answer is "no" there is no need to perform an operation.

- **Temporary rail would be used as a permanent barrier?** If temporary rails are used during construction, will they be used later as permanent rails? Move the mouse to the square next to this question and click with the left mouse button if the answer is "yes." If the answer is "no" there is no need to perform an operation.
2.2.5 Editing Weights of Importance

Weights of importance are edited by selecting Weight of Importance from the Edit menu. A dialog box appears (Fig. 17). Each weight of importance is a number between 1 and 10 that controls the importance of a category in selecting a rail type. The five categories for control are as follows:

- Cost
- Maintenance
- Strength
- Aesthetics
- Personal Preference

A weight of 10 means that the category (or criteria) is extremely important for the selection of a rail type. For example, if a weight of 10 is assigned to cost, this means that the least expensive rail from among all possible candidates is going to be given the most weight in the selection process. A weight of 1 means that the criteria is not at all important in selecting a rail. For example, if a weight of 1 is assigned to cost,
the construction cost of the rail will be given very little weight when comparing candidate rails.

In case all criteria are equally important, the weight of 7 or higher is recommended. As explained above, the lower the weight, the less important the criterion is. However, if the weight is too low (less than 6) the criterion is not important at all. Therefore, if very low weight is assigned to each criteria, all candidates will be rated to be equally qualified, since all criteria are not important. The result should not be considered trivial. Even though some candidates are actually better than the others, the margin of difference is minimized by assigning very low weights of importance.

![Screenshot of Bridge Rail Expert System](image.png)

**FIG. 17. Dialog Box for Weights of Importance**

To assign the value of weight to a category, move the mouse to the rectangle next to the name of the category and click once with the left mouse button. Use the keyboard to enter the weight. Enter only integers between 1 and 10.
2.2.6 Editing Existing Bridge Data

This submenu is designed only for the retrofit version of BREXS. It accommodates acquisition of existing bridge geometry. Selecting this submenu under Edit invokes the dialog box as shown in Fig. 18. The button with the label "Edit Existing Slab..." allows input of the type of bridge deck and its dimensions. The first check box indicates the existence of slots for draining water that are normally located at the toe of the curb. The second check box indicates the existence of a construction joint between the slab and curb.

![Dialog Box for Edit Existing Bridge Data](image)

**FIG. 18. Dialog Box for Edit Existing Bridge Data**

Clicking on the button with the label "Edit Existing Slab..." invokes a graphics window that shows a slab and a dialog box for input of the slab dimensions. An example of this screen is shown in Fig. 19. The NEXT and PREVIOUS buttons in the Slab Dimensions box are helpful for choosing the slab type that is similar to the existing bridge structure. The input fields a, b, c, d, e, x, y, and z correspond to the dimensions shown in the slab drawing window. All input fields are not applicable to all types of slabs. BREXS prohibits input of irrelevant fields. Movement between
the input boxes can be done by mouse or with the tab key. Fig. 20 shows each type of bridge deck that is available in the database of BREXS.

![Bridge Rail Expert System - sample.net](image)

FIG. 19. Slab Drawing Window and Slab Dimensions Input Dialog Box
FIG. 20. Types of Bridge Decks Available in BREXS' Database
2.3 Execute Menu

2.3.1 Running the Advisory Program

To run the advisory program select the Run Advisory Program option from the Execute menu. This starts execution of the program with the data provided. During execution, several messages are written to the screen (Fig. 21) and user responses are requested.

If the data submitted is for a New case, i.e., no existing data file was opened, then program execution is only possible after all of the case data has been entered and saved. This means that each of the five sets in the Edit menu has been accessed and edited as needed. This can be easily verified by observing the check marks next to the choices in the Edit menu.

If data submitted was read from a data file and was not edited before execution, a message box appears with a warning. The user is given the choice of either verifying that the data need not be edited or aborting the execution.

When the advisory program terminates its execution a message is displayed that asks if the user would like to view the results. If the user opts to bypass viewing the results at this prompt, they may be viewed at a later time using the Results menu.

![Image](image_url)

FIG. 21. Message to User During Execution
2.3.2 Draw

This menu is applicable only for the retrofit version of BREXS. **Draw** allows the user to view the drawing of the existing bridge slab and candidate rails in a variety of positions relative to the edge of the slab. It also allows the user to visualize and experiment with alternative placement positions of rails on the bridge slab. The **Draw** submenu, which is a submenu under **Execute**, is activated only after input of existing bridge data are completed. Selecting the **Draw** menu invokes a window as shown in Fig. 22.

![Draw Window](image)

**FIG. 22. Draw Window**

There are three menus within the **Draw** window: **File**, **Rail Type**, and **Options**. **File** allows printing (**Print**) and exiting from **Draw** (**Exit**). The **Rail Type** menu shows candidate rails that resulted from execution of the advisory program. Choosing a rail name listed under this menu causes a graphic image of that rail to be placed on the bridge slab at the optimal position recommended by BREXS. The list of rail names under the **Rail Type** menu is blank if this menu is selected before running the advisory program. Fig. 23 shows an example drawing of a T4 rail on a pan form slab along with explanatory text.
Position of the rail can be altered by using a mouse or the arrow keys. With the mouse, place the pointing arrow at the location where the rail is to be placed and click with the left button of the mouse. The **Options** menu allows for changes of the rail drawing.

*BREXS* gives a warning message in case the rail is placed too close to the face of a girder where anchoring is difficult or can not be done. A message above the drawing describes the position of the rail from the edge of the slab. It should be noted that alternative positions of rail are not warranted to be valid by *BREXS*. That is, the optimum position for placement of the rail is used to determine the relative ranking and suitability of each type of railing. The user must use engineering judgement to evaluate the validity of the alternative positions. In most cases only a slight adjustment from the optimal position is recommended.

![Diagram](image)

**FIG. 23. T4 Rail Placed at the Optimal Position**
2.4 Results Menu

This menu includes functions that handle results obtained from the advisory program after it has executed using the current input data. Entries in this menu can be activated only after the advisory program has been run. If an entry is selected before running the advisory program, a message box appears on the screen to inform the user about the erroneous selection.

2.4.1 How to View Recent Results

Only after executing the advisory program can results be displayed on the screen. To view these results select Show Results from the Results menu. This selection creates a child window (Fig. 24) in which results are displayed in the form of a ranked list of potential bridge rails that are recommended by the advisory program. If a rail type is not shown the program has come to the conclusion that it should not be used. Each recommended rail in the list is associated with a weight. The larger the weight, the more the rail is recommended.

![Figure 24. Results Window](image-url)
Results are read from the file "RANK_OUT.NXP." This file is overwritten each time the advisory program is executed. Hence, only results of the current or most recent run can be viewed in the results window.

2.4.2 Closing the Results Window

The Results window is closed by moving the mouse to the far left corner at the top and clicking twice with the left mouse button. Unless this action is performed, the Results window is continuously displayed. All child windows, including the Results window, are closed when BREXS is terminated.

2.4.3 Saving Results to a File

Results can be saved to a file by selecting Save Results from the Results menu. A dialog box asks for a filename with an optional extension .RSL. The results are saved along with the case data in the file specified in the dialog box. If results have been previously saved to a file and need to be viewed, an external editor can be used. The Microsoft Windows NOTEPAD editor, which is available with Windows 3.0, can be readily used for this purpose. This editor can be accessed by choosing View Old Results File from the Results menu.

2.4.4 Printing Results

Results can be printed by selecting Print Results from the Results menu. They are printed in the same format as used for the Results window. To set up the printer refer to the Microsoft Windows User's Guide (Microsoft 1990).

2.4.5 How to View Old Results

Old results are those of cases other than the case currently under investigation. If results of a previously run case have been saved to a file, they can be accessed by choosing View Old Results File from the Results menu. This causes an external editor, NOTEPAD, to display the chosen results file. Before accessing the editor, a dialog box similar to that of Fig. 10 is displayed. The dialog box asks for a results filename, possibly with an extension .RSL. When the OK button is selected, the NOTEPAD editor is opened with the chosen file displayed in its window. Note that this editor window is not automatically closed when BREXS is terminated. Therefore, it needs to be terminated separately.
2.5 Rail Types Menu

This menu supplies functions that access the rail types database. Records in the database can be viewed, one at a time, with all the fields of one record displayed (Fig. 25). Records can be added to the database, deleted from the database, or edited. The database is stored in an ASCII file with the name "DATABASE.NXP."

2.5.1 Rail Types Database Record Structure

Each record in the database consists of the following fields, arranged in alphabetical order:

- **Approach:** Indicates whether or not the rail requires a long or a short approach distance.
- **Construction:** Describes the method in which the rail can be built.
- **Height:** Gives the height of the rail measured in inches.
- **Material:** Describes the material from which the rail is built.
- **Openings:** Indicates whether or not the rail has any openings. There are three choices for this field:
  - *Large Openings:* Such as the T202 rail or the T6 rail.
  - *Small Openings:* Such as the T502 rail.
  - *No Openings:* Such as the T501 rail.
- **Performance:** Gives the performance level of the rail type.
- **Relative Rank:** This is a number between 1 and 10 that ranks the rail relative to other rail types according to the following categories:
  - **Strength:** The ability of the rail to withstand impact.
  - **Maintenance:** The higher the rank, the smaller the number of resources it takes to maintain the rail.
  - **Aesthetics:** The higher the rank the more eye-pleasing the rail is considered to be.
  - **Cost:** The higher the rank the smaller the cost of the rail.
  - **Personal Preference:** This indicates preference of the rail for reasons other than cost, maintenance, aesthetics, or strength. The higher the rank, the more preferred the rail is.
- **Shape:** Describes the geometric shape of the face of the rail. The are three choices in this field:
  - **Safety Shape:** Sometimes called New Jersey type barrier, such as the T501.
  - **Vertical Shape:** Similar to a straight wall such as the T201.
*Posts:* Any rail that has posts, such as the T101 or T6.

- **Stiffness:** Rates the yielding potential of the rail on impact. For example, the T6 is considered to be yielding, while T501 is a rigid barrier.
- **Visibility:** Rates the visibility provided by the rail to passengers in vehicles.

### 2.5.2 Accessing the Rail Types Database

To access the rail database select **Access Rail Type Database** from the **Rail Types** menu. A dialog box similar to Fig. 25 is displayed.

![FIG. 25. Dialog Box for Rail Types Database](image)

### 2.5.3 Browsing the Rail Types Database

To view records of rail types use the push buttons on the screen labeled **Next Record** or **Previous Record** that are located at the top of the dialog box. This results in changing the fields of the record to correspond to the current rail being displayed. The name, or type, of the rail is displayed in the middle at the top of the dialog box. If the **Show Rail Types** window is open, the rail type displayed in that window is also changed when the records are changed.

### 2.5.4 Adding a New Record to the Rail Database

To add a new record move the mouse to the **Add New Rail Type** button and click once with the left mouse button. This enables the dialog box for editing.
the record to be added as explained in the section below. After all fields have been edited move the mouse to the Add New Rail Type button and click once more with the left mouse button. The new record is added to the database only if EXIT and SAVE is chosen when exiting this operation. If Cancel is chosen as the option for exiting from database access, any changes made to the database may be lost.

2.5.6 Editing Records in the Rail Types Database

The value of a field in a record can be changed by selecting the field and entering a new value or by altering the selection at that field. For example, to change the Relative Rank of Cost of a given record, move the mouse to the box next to Cost and click the left mouse button once. Using the keyboard, delete the old value and enter a new value. For example, to change the Material field of a given type of rail from Metal to Concrete, move the mouse to the position where Concrete is displayed and click once with the left mouse button. This results in checking the small circle by the word Concrete. Changes made to fields and records are saved only if the Exit and Save button is pressed when quitting. Note that while editing a record, the buttons Next Record, Previous Record, and Delete Rail Type are disabled.

2.5.7 Deleting Records from the Rail Database

To delete an existing record from the rail database click with the left mouse button on Previous Record or Next Record until the record to be deleted is displayed in the dialog box. Move the mouse the Delete Rail Type button and click once with the left mouse button. The record is not actually deleted from the database until the Exit and Save button is pressed. If the Cancel button is used to exit from the database access, any record deletion or change made to the database is lost.

2.5.8 Viewing a Cross Section of a Rail Type (Show Rail Window)

To display a cross section of a rail type select Show Rail Types from the Rail Types menu. A child window appears with a graphical image of a cross section of a rail type. Its name is displayed at the top of that window (Fig. 26). Use the Page Down and Page Up keys to view more rail types. Another way to change the rail type displayed in the window is to click with the left mouse button on the Next Record or Previous Record options in the Rail Types database dialog box.
2.5.9 Closing the **Show Rail Types Window**

When viewing of the rails is complete, close the **Show Rail Types** window by moving the mouse to the top far left corner and clicking twice in rapid succession on the left mouse button. Unless this action is performed, the **Show Rail Types** window is continuously displayed. All child windows, including the **Show Rail Types** window, are closed when **BREXS** is terminated.

![FIG. 26. Show Rail Window](image)

2.6 **Help Menus**

2.6.1 How to Get Help

A subset of this user's manual for **BREXS** is stored in a group of files named "**BREXS.HLP."** Each section in this manual can be accessed separately by choosing the corresponding entry from the **Help** menu. The MS-Windows Help System is used to display the help information. When an item is chosen from the **Help** menu, the Windows Help System is invoked. This program facilitates the delivery of help information to the user. It provides an index, a keyword look-up, and several other
facilities. Note that the Help System needs to be terminated by the user, when done browsing the help information.

2.6.2 About BREXS

When this option is selected from the Help menu, information is displayed about the program. The icon associated with BREXS is also displayed (Fig. 27).

![FIG. 27. Help Menu with BREXS Information](image-url)
III. Sample Session

An example of the usage of BREXS is presented in this chapter. This relatively detailed outline of the rail selection process is intended to give the reader an understanding of the high degree of integration of the analysis and inference engine modules with the control module and the user interface. It also demonstrates that the graphical interface provides numerous advantages over a lengthy series of conventional alphanumeric query and response interchanges between the user and the machine. Further details of the knowledge base and other aspects of BREXS are explained more fully in the companion reference by Roschke et al. (1991).

To allow consistency with other Microsoft Windows applications, the user interface for BREXS conforms to the "Common User Access: Advanced Interface Design Guide" (1989). The main window features File, Edit, Execute, Results, Rail Types, and Help menus as shown in Fig. 8. File menu supports file handling functions. Edit accommodates data input. Execute is for execution of the advisory program. Results Rail handles results files. Rail Types allows access to the bridge railing database. Help provides on-line documentation for BREXS.

The example presented in the following narrative and graphic description demonstrates a retrofit railing problem. The main window (Fig. 8) appears after invoking the BREXS' retrofit program. Since this example is presented as a totally new case, the New submenu under File is selected. The user then proceeds to edit the data accommodated by submenus under Edit menu. Submenus under Edit are Existing Bridge Data, Roadway Data, Bridge Data, Environment Information, and Weight of Importance. Each submenu corresponds to an interactive dialog screen. The submenu Existing Bridge Data invokes the window shown in Fig. 28. The button labeled Edit Existing Slab ... is for input of the existing bridge geometry. Two check boxes are for indication of the existence of drains and construction joints, respectively. In this case, both boxes are checked. Using a mouse to click on the Edit Existing Slab ... button invokes the window with a bridge drawing and a dialog window for input of the dimensions of the corresponding bridge. The user can search for the bridge structure that is similar to the bridge in question by means of NEXT and PREVIOUS buttons. Type and dimensions of the bridge slab are used
for checking the compatibility of the candidate rail. In this session a bridge cross-
section that has a pan form with an overhang is selected as shown in Fig. 29.

**FIG. 28. Existing Bridge Structure Data Input Screen**

**FIG. 29. Slab Type and Dimension Input Windows**
The user then proceeds to input the information via **Roadway Data, Bridge Data, Environmental Data, and Weight of Importance** submenus under the **Edit** menu in the main window of **BREXS**. The dialog screens and data used in this session are shown in Figs. 30-33, respectively. Weight of importance allows the user to assign relative importance of the five attributes. This information, relative rating of rails, and results of evaluation from the inference engine affects the overall rating and ranking of the candidate rail. They are used as input to the fuzzy logic decision-making mechanism (Roschke 1991).

The interface of **BREXS** is capable of trapping input typing mistakes and out-of-range data (e.g., a bridge having a length 0.0 ft, and a traffic volume of $2000 \times 1000$ vpd). Even though the knowledge bases of **BREXS** are capable of checking and solving for numerous serious conflicts between the given information, all possible mistakes are not fully checked and professional judgment and reasonable caution are urged. Users are advised to ensure that the input data concurs with reality. A summary of input data chosen for this sample session is shown on the main window (Fig. 28).

At this point, the user can save the input data to a file by means of the **Save** submenu under the **File** menu. Existing data files can also be called and printed by **Open** and **Print** submenus, respectively.

After entering all data, the user proceeds to execute the advisory program (the advisory program here refers to a subroutine that controls and executes the inference engine, the Benefit/Cost Analysis Program (BCAP), and other supporting analysis codes). **BREXS** automatically invokes the inference engine to derive the solution. The inference engine in tandem with the knowledge bases derives a set of candidates rails based on the input data. It also evaluates each candidate rail according to the five aspects discussed earlier. **BREXS** prepares a data file, and then invokes execution of BCAP. The results from the inferred process and execution of BCAP are then passed to the fuzzy logic decision-making module that rates and ranks the remaining candidate rails.
FIG. 30. Highway Information Screen

FIG. 31. Bridge Data Screen
FIG. 32. Environment Information Screen

FIG. 33. Parameter Weighting Data Screen
At this point execution of the advisory program is complete. The user can view the list of selected rails with a corresponding rating as shown in a window (Fig. 34). Results of execution along with the input data can be printed or saved to a file for future reference via submenus under the Results menu.

Choice of rails, placement position on the slab, and types of anchor (dowel or bolt) are interrelated and effect each other. BREXS gives the recommendation of an optimal position for placement of each candidate rail. The user can view the graphical image of the recommended position of each rail on the bridge slab by selecting the Draw submenu under Execute. Figs. 35 and 36 show drawings of the T4 and T501 rails, respectively, on the slab at the recommended horizontal position from the edge of the slab. To enhance visualization of other options, BREXS also allows horizontal movement of the rail relative to the slab with a mouse or with the keyboard arrow keys. This function facilitates visual experimentation with alternative placement. It also allows an engineer to slightly adjust the position of the rail to avoid reinforcing bar conflicts between the existing bridge and the new rail.

![Screen capture of BREXS retrofit application](image)

**FIG. 34.** List of Selected Rails

<table>
<thead>
<tr>
<th>Rail Type</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>T201</td>
<td>5.0</td>
</tr>
<tr>
<td>T302</td>
<td>5.0</td>
</tr>
<tr>
<td>T4</td>
<td>5.0</td>
</tr>
<tr>
<td>T501</td>
<td>4.0</td>
</tr>
</tbody>
</table>

Average Daily Traffic = 1,000 vpd

- Desired Roadway Width is 30 ft.
- There is a record of multiple impacts
- Rail Offset is 0 to 3 ft. from edge of travelway to face of rail
- Type of Understructure = Deep Water
- Grade = 0.0 Percent
- Curvature = 0.0 Degrees
- Bridge Length = 1000.0 ft.
- Bridge Width = 45.0 ft.
- Deck Thickness = 7.0 in.

---

39
FIG. 35. Recommended Placement Position on the Slab (T4)

FIG. 36. Recommended Placement Position on the Slab (T501)

Bridge engineers can also access the bridge rail database that contains properties of the standard rails and their drawings. Existing railing information can be updated or adjusted to reflect preference or policy of an individual district. New standard rails also can be added to the database as they are approved.
APPENDIX I. REFERENCES


